/ / Django 1.5: Python 2.7 или Python 3 - django, python-2.7, python-3.x

Django 1.5: Python 2.7 или Python 3 - django, python-2.7, python-3.x

Джанго просто пускат версия 1.5.

Сега той поддържа Python 3, въпросът ми е достапросто: С тази версия 1.5 трябва ли да използвам Python 2.7 или Python 3? Предполагам, че с Python 3 ще има някои проблеми с 3rd party app no?

Във вашия случай, какво ще направите?

Отговори:

5 за отговор № 1

В бележките за изданието се посочва ясно, че Python 3 поддържа 1.5 експериментален, И да, приложения на трети страни ще бъдат проблем.


0 за отговор № 2

Ако започнах ново развитие, което азне очаквах да вляза живи, докато след пускането на версия 1.6 (когато поддръжката на Python 3 се очакваше да е готова за производство и надявам се, че приложенията на трети страни са се появили), тогава да, ще отида с Python 3. Това е значително по-чист от Python 2.7.

Но ако искате в близко бъдеще сайтът Ви да бъде пуснат в действие, останете с 2.7.


0 за отговор № 3

Аз все пак ще използвам Python 2.7, защото много приложения и библиотеки не са готови за Python 3.x

PIL не работи правилно с Python 3