/ / swift werde ich gezwungen sein, den Code meiner App neu zu erstellen, wenn swift 2.0 veröffentlicht wird - ios, swift, swift2

swift wird gezwungen sein, den Code meiner App neu zu erstellen, wenn swift 2.0 veröffentlicht wird - ios, swift, swift2

Ich habe eine App mit swift 1.2 erstellt.

Wird ich gezwungen sein, meine gesamte Verwendung von swift 2 neu zu erstellen, wenn es veröffentlicht wird? Oder kann ich mit dem schnellen 1.2-Code noch Aktualisierungen an meiner App vornehmen?

Antworten:

2 für die Antwort № 1

Ich verstehe, dass Xcode 7 Swift 2 und Xcode 6.x Swift 1.2 verwendet.

Apple wird wahrscheinlich weiterhin Xcode 6 unterstützen.x für einige Zeit nach Xcode 7 geht GM. Während dieser Zeit sollten Sie in der Lage sein, Ihren Swift 1.2-Code zu unterstützen. Es ist jedoch keine gute Idee, sich auf alte Entwicklerwerkzeuge zu verlassen. Sie sollten darüber nachdenken, zu Swift 2 zu migrieren, sobald Xcode 7 veröffentlicht ist.


0 für die Antwort № 2

Als ich xcode 7 benutzt habe.Beta 4, ich konvertierte meinen Code für Swift 2. Als ich den gleichen Code mit xcode 7.beta 5 lief, stieß ich wieder auf einige schnellere Fehler. Bleib ruhig, bis Apple die finale xcode-Version veröffentlicht, die swift 2+ unterstützt