/ / Django 1.5:Python 2.7またはPython 3 - django、python-2.7、python-3.x

Django 1.5:Python 2.7またはPython 3 - django、python-2.7、python-3.x

Djangoは1.5バージョンをリリースします。

今はPython 3をサポートしています。私の質問はかなりです確かに単純です:この1.5バージョンでは、私はまだPython 2.7またはPython 3を使うべきですか?私は、Python 3ではサードパーティ製のアプリケーションにいくつかの問題があると想定していますか?

あなたの場合、あなたは何をしますか?

回答:

回答№1は5

リリースノートには、1.5でPython 3のサポートが 実験的。そして、はい、サードパーティのアプリが問題になります。


回答№2の場合は0

私が新しい開発を始めていたら、私はバージョン1.6がリリースされてから(Python 3のサポートがプロダクションになるはずですが、サードパーティ製のアプリケーションがうまくいけば)、Python 3を使うつもりです。 Python 2.7よりもクリーンです。

しかし、近い将来にあなたのサイトを稼働させたいなら、2.7を守ってください。


回答№3の場合は0

多くのアプリケーションとライブラリはPython 3.xの準備ができていないので、まだPython 2.7を使用します

PILがPython 3で正しく動作しない