/ / Django 1.5: Python 2.7 lub Python 3 - django, python-2.7, python-3.x

Django 1.5: Python 2.7 lub Python 3 - django, python-2.7, python-3.x

Django wydaje właśnie wersję 1.5.

Obsługuje teraz Python 3, moje pytanie jest dośćbardzo proste: z tą wersją 1.5, czy nadal powinienem używać Pythona 2.7 lub Pythona 3? Zakładam, że w Pythonie 3 pojawią się problemy z aplikacją 3rd parties?

W twoim przypadku, co byś zrobił?

Odpowiedzi:

5 dla odpowiedzi № 1

Uwagi do wydania jasno stwierdzają, że wsparcie dla Pythona 3 w wersji 1.5 jest eksperymentalny. I tak, aplikacje innych firm będą problemem.


0 dla odpowiedzi nr 2

Jeśli zaczynałem nowy rozwój, który janie spodziewałem się, że zacznie działać, dopóki nie pojawi się wersja 1.6 (gdy wsparcie dla Pythona 3 ma być gotowe do produkcji, i mam nadzieję, że aplikacje innych producentów się dogoniły), to tak, poszedłbym z Pythonem 3. Jest znacząco czystsze niż Python 2.7.

Ale jeśli chcesz, aby Twoja strona działała w najbliższej przyszłości, pozostań przy 2.7.


0 dla odpowiedzi № 3

Nadal będę używać Pythona 2.7, ponieważ wiele aplikacji i bibliotek nie jest gotowych na Pythona 3.x

PIL nie działa poprawnie z pythonem 3