/ / Python und Django Versionsausgabe - Python, Django

Python und Django Versionsausgabe - Python, Django

Ich wurde empfohlen, um eine Website mit Python - Django Framework (anstelle von PHP) zu erstellen.
In seiner Dokumentation sagt Django, dass es nicht kompatibel mit Python-Version höher als 2,7 ist.
Auf der Python-Download-Seite ist die niedrigste verfügbare Version 2.73.
Irgendein Rat ?

Antworten:

5 für die Antwort № 1

Django 1.4 und das kommende 1.5 werden mit Python 2.7.3 funktionieren.

Wenn Django Python 2.7 sagt, bedeutet das 2.7.X. Sie können jede Version von Python 2.7 verwenden, einschließlich 2.7.3.

Von dem Django 1.5 faq:

Django benötigt Python, speziell Python 2.6.5 - 2.7.x. Für die grundlegende Django-Verwendung sind keine anderen Python-Bibliotheken erforderlich. Django 1.5 bietet auch experimentelle Unterstützung für Python 3.2.3 und höher.