/ / Python 2.6.4 unterstützt mod_python nicht? - Python, Django, Mod-Python

Python 2.6.4 unterstützt mod_python nicht? - Python, Django, Mod-Python

bin auf der Suche nach einer Möglichkeit, Django mit nur meinem Xampp zu laufen, und ich stieß online in dieses Tutorial http://jyotirmaya.blogspot.com/2008/11/xampp-python-django.html laut dem Autor, mod_python 3.3.1 wird nicht von Python 2.6 unterstützt, aber der Blogpost wurde vor mehr als einem Jahr erstellt, denke ich. ist das noch immer so? oder es ist in Ordnung, wenn ich 2.6 verwenden und es mit mod python 3.3.1 kombinieren werde?

Antworten:

6 für die Antwort № 1

mod_python muss gegen das spezifische kompiliert werdenVersion von Python, in der der Handler ausgeführt wird. Zu der Zeit gab es wahrscheinlich kein Windows-Installationsprogramm für mod_python, das gegen 2.6.4 gebaut wurde, daher die Hysterie.

In aller Fairness solltest du wahrscheinlich verwenden mod_wsgi um stattdessen Django-Apps zu starten.