/ / Zope installiert in falsche Version (easy_install und Pip) - Python, Macos, Twisted, Zope, Ei

Zope installiert in falscher Version (easy_install und Pip) - Python, Macos, Twisted, Zope, Ei

Ich habe das Python-Ei für Zope heruntergeladen.Schnittstelle Version 4.0.5 und versuchte, es mit easy_install und dann pip zu installieren. Beide haben es auf Python 2.7 installiert, das ist der Standard auf meinem Computer. Gibt es eine Möglichkeit, es auf Python3 zu installieren?

Ich bin auf Mac OSX 10.8.3. Ich habe nach einer Lösung gesucht, aber die einzige, die ich mit diesem Problem gefunden habe, war hier: easy_install mit verschiedenen Versionen von Python installiert, Mac OSX, aber die Antwort funktioniert nicht.

Antworten:

1 für die Antwort № 1

Ich würde vorschlagen, das zu installieren Homebrew Paket-Manager, und installieren Sie Python 3 damit.

Homebrew installieren:

ruby -e "$(curl -fsSL https://raw.github.com/mxcl/homebrew/go)"

Installieren von Python 3

brew install python3

  • Pip für Python 3 würde durch den obigen Befehl als pip3 installiert werden.
  • easy_install ist mit Homebrew depretiated, und Sie brauchen nicht zu verwenden sudo mit pip3 oder gem

Hinweis, easy_install ist veraltet. Wir installieren pip (oder pip3 für python3) zusammen mit python / python3.

Quelle